# 快速部署

# 环境要求

ThinkPHP5.1的环境要求如下:

  • PHP >= 5.6.0
  • PDO PHP Extension
  • MBstring PHP Extension

# 更新依赖库

如果还没有安装 Composer,在 Linux 和 Mac OS X 中可以运行如下命令:

curl -sS https://getcomposer.org/installer | php
mv composer.phar /usr/local/bin/composer
1
2

在 Windows 中,你需要下载并运行 《Composer-Setup.exe》。 如果遇到任何问题或者想更深入地学习 Composer,请参考Composer 文档(英文文档,中文文档)。

框架本身已经全部安装好了第三方依赖包,无需再次安装,如果单独引入其他依赖包仍然需要您安装Composer手动去安装一下依赖;

更新之前需要更换镜像源 配置全局生效

composer config -g repo.packagist composer https://mirrors.aliyun.com/composer/
1

取消全局配置

composer config -g --unset repos.packagist
1

重要通知:

TIP

鉴于近期网上下载的项目运行报错的问题,请大家自行更新一下第三方库,在命令行终端项目根目录输入:composer update 更新第三方依赖库